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SIMULATING THE SURFACE OF LITCHI GRAIN LEATHER BY CREATING QUADRILATERAL-CONTINUOUS PATTERN IN ADOBE ILLUSTRATOR
cc

ABSTRACT. The paper illustrates an approach of creating quadrilateral-continuous pattern for simulating litchi grain leather surface in order
to solve the issue that the designer of leather products cannot simulate litchi grain surface simply or realistically. Adobe Illustrator CC is a
kind of design software that possesses pattern-editing mode. Based on both the image of the litchi grain leather sample scanned by stereo
microscope and the rationale behind the quadrilateral-continuous pattern, we obtained the wrinkles and pores of litchi grain leather sample
in Adobe lllustrator CC without using any sophisticated algorithm, which in turn resulted in realistic and various effects on the surface of litchi
grain leather. Moreover, the pattern exported from Adobe Illustrator CC can also be widely used in other kinds of design software.
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SIMULAREA SUPRAFETEI PIELII CU MODEL IN RELIEF PRIN CREAREA UNUI MODEL PATRULATER CONTINUU N ADOBE ILLUSTRATOR CC
REZUMAT. Lucrarea prezinta o abordare a credrii unui model patrulater continuu de simulare a suprafetei pielii cu model in relief pentru a
rezolva problema cu care se confruntd designerul de produse din piele care nu poate simula suprafata pielii in mod simplu sau realist. Adobe
Illustrator CC este un software de design care permite modelarea tiparelor. Pe baza imaginii scanate la stereomicroscop a probelor din piele si
pe baza rationamentului din spatele modelului patrulater continuu, am obtinut ,ridurile” si ,porii” de pe suprafata pielii in Adobe Illustrator
CC f4ré a utiliza niciun algoritm sofisticat, obtinand efecte realiste si diverse pe suprafata pielii. In plus, modelul exportat din Adobe Illustrator
CC poate fi folosit pe scara larga si in alte tipuri de software de design.

CUVINTE CHEIE: piele cu model in relief, model patrulater continuu, Adobe lllustrator CC, simularea suprafetei

SIMULER LA SURFACE DU CUIR EMBOSSE EN CREANT UN MOTIF QUADRILATERAL CONTINU DANS ADOBE ILLUSTRATOR CC
RESUME. Cet article présente une approche permettant de créer un motif quadrilatéral continu pour simuler une surface de cuir embossé
afin de résoudre le probleme selon lequel le concepteur de produits en cuir ne peut pas simuler de maniére simple ou réaliste une surface
de cuir embossé. Adobe lllustrator CC est une sorte de logiciel de conception doté du mode d’édition de motifs. Sur la base de I'image de
I’échantillon du cuir scanné au stéréomicroscope et de la logique du motif quadrilatéral continu, nous avons obtenu “les rides” et “les pores”
de I’échantillon de cuir embossé dans Adobe Illustrator CC sans utiliser d’algorithme sophistiqué, en obtenant des effets réalistes et variés sur
la surface du cuir embossé. De plus, le motif exporté depuis Adobe Illustrator CC peut également étre largement utilisé dans d’autres types
de logiciels de conception.

MOTS CLES: cuir embossé, motif quadrilatéral continu, Adobe Illustrator CC, simulation de la surface
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INTRODUCTION

Litchigrainisoneofthemostpopularleather
knurling textures which show a stereoscopic,
roughened, distinct leather surface. Litchi grain
leather (LGL) has characteristics of being soft,
durable, comfortable and is commonly used
for making leather products. It burnishes and
beautifies as time goes by, developing a sought-
after patina with unique character that can not
be easily duplicated. This predicament occurs
when designers simulate LGL merchandise and
is used for texture mapping. It is a slow process
and difficult to simulate the grained surface as
it consistently looks artificial and unrealistic as
well.

The texture synthesis technique is the best
tool to solve these issues [1]. Some approaches
that have been proposed for leather texture
synthesis are physical simulation [2], which
synthesizes the leather texture by directly
simulating its physical generation processes and
can model using cellular texturing [3, 4] as well
as reaction diffusion [5, 6]. These techniques
can generate textures directly with an efficient
algorithm, but it is difficult for leather products
designers to design an algorithm.

We hypothesise that the quadrilateral-
continuous pattern (QCP) of LGL could be
generated by a generic software, which could
generate a unit that represents the appearance
and structural elements of the LGL surface. The
visualization, texture mapping and rendering of
the LGL merchandise will be accelerated and
more convenient.

The solution described in this study
addresses the realistic requirement to accurately
generate a vector quadrilateral-continuous
pattern of LGL utilizing Adobe® lllustrator® (Al).
An important attribute of such a continuous unit
can be fast and efficient for leather products
designers. Furthermore, this kind of vector
guadrilateral-continuous pattern will not be
distorted, the parameters can be transformed
and the pattern can be modified to other
appearances automatically and subtly. Moreover,
the LGL quadrilateral-continuous pattern made
by Al can be saved as many corresponding
formats with high resolution, in order to use it
for other software.

EXPERIMENTAL

Materials

Olympus SZX12 stereo microscope,
equipped with a full-fledged optical system
featuring a zoom ratio of 13, in order to obtain
skeletons with informative LGL surface structural
elements for referencing.

MShot Digital Imaging System, a program
designed for a microscope camera to connect
with the computer in order to view, capture,
measure and process the LGL surface.

Adobe lllustrator CC, QCP of LGL can be
customized from scratch with many tools in
Adobe lllustrator.

Methods

Obtaining Referenced Skeletons

Olympus SZX12 Stereo Microscope
equipped with a full-fledged optical system
featuring a zoom ratio of 13 was utilized. There
was a collaboration between the MShot Digital
Imaging System v1.0 connected with the stereo
microscope and the computer in order to view
and capture the LGL surface. Figure 1is a scanned
piece of the LGL sample image under 10 times
the stereo microscope. Lines and points were
generated which represent skeletons in order
to analyze and extract informative LGL surface
structural elements (i.e. cristae, sulci, wrinkles,
pockets and pores) for referencing [7, 8].

Figure 1. Scanning LGL sample image under 10
times the stereo microscope
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Rationale of the Quadrilateral-Continuous
Pattern

The quadrilateral-continuous pattern, also
known as seamless repeat pattern or pattern
tile, is a small artwork repeated next to each
other in a seamless way that appears to be one
single artwork. Figure 2 is an illustration of the
rationale generating QCP, as an ordinary triangle
was used as the element in this paradigm.

The broken lines represent the pattern
bounding box which is an unfilled and unstroked
(non-printing) rectangle. For filling patterns,
the bounding box acts as a mask and defines a
portion of the pattern tile which indicate that
the fragmentary triangle on the right inner
side should be completed on the left inner
side. The same goes for the top and bottom
positioning. After perfecting some details, a
triangle quadrilateral-continuous pattern will be
generated and appears repetitively without any
flaws [9, 10].

IN ADOBE ILLUSTRATOR CC

Figure 2. lllustration of the rational generating
seamless repeat pattern

Rationale of Generating QCP in Al

According to the rational above, the
production of the quadrilateral-continuous
pattern was not always an easy task, requiring
precision and patience. Nevertheless, with Al
CS6 and later version CC, this process became
automatic and accelerated. The pattern design
tools are accessed through a new menu item:
Object > Pattern > Make. Designers are taken
into a new pattern generation mode, controlled
by a new Pattern Options panel which offers a
greater level of control over patterns.

The benefits of generating QCP by Al
are not only described above but also because
designers can set the repeating behavior by 5 tile
type options in the Tile Type pull-down (i.e. Grid,
Brick by row, Brick by column, Hex by column,
and Hex by row) without having to figure out the
algorithm that is needed to do it manually. These
tile types enrich the style of SPR.

The Grid tile type follows the rationale of
QCP described above, because of this, the Brick
Offset value could be changed in Brick by row
and Column which can interactively tweak the
effects of Grid tile type. Moreover, the bounding
boxes of Hex tile type have two more boundary
handles than Grid type, a shape of hexagon
thatcan create more varied effects. Figure 3
presents the pattern operation interface that
contains tile types in Al and the differences of
bounding box and rationale between grid tile
type and hex tile type.
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Pattern Options

Mame: FGL Pattern
Tile Type: B Grid
v
25 Brick by Row
Width: B Brick by Column
Height:  Hex by Column
) Hex by Row
[J Move Tile with Art

Overlap: <

Copies: 1x1 el

Dim Copies to:  100% v

[_J Show Tile Edge
] Show Swatch Bounds

Bounding box of hex tile type

Figure 3. Pattern operation interface of Al & Different bounding boxes and rationales of grid tile type
and hex tile type

Generate Wrinkles of LGL Surface

Following the operation procedures give
instructions about generating the Grid type
QCP of LGL surface as a paradigm using the
latest version CC of Al. Brick type and Hex type
are based on Grid type and after knowing the
principle of generating Grid type pattern, it is
easy to generate the other four kinds of QCP in
Al. Keyboard shortcuts in brackets are given in
this study.

Open Adobe lllustrator and create a new
document named QCP of LGL (Cmd/Ctrl + N).
Set the units as pixels, color mode as RGB and
raster effects as 300 ppi. Place the scanning
stereo microscope image into the document
(File > Place > Embed). The skeleton of LGL will
be extracted from referring to this image.

Based on the size of the placed raster
scanning stereomicroscope image, create a
rectangle using the Rectangle Tool (M) and set
both the fill color and stroke color to None.
Select the image and rectangle and set the Align
as Horizontal Align Center and Vertical Align
Center. This rectangle will play a crucial role
when coloring the underpainting of LGL.

Select the image and rectangle, then go
to Object > Pattern > Make, which changes to

Pattern Editing mode. Lock the two layers and
set the stroke color as R=25, G=25, B=25. Select
the Tile type as Grid, overlap as Left in Front and
Top in Front. Use the Copies pull-down to add
repeats which can control the visibility (dimming,
edges and bounds) of pattern tile, and keep these
settings as the defaults. There will be a rectangle
with the same size of the image which plays the
role of the boundary box. Continue creating
the skeleton of wrinkles while referring to the
wrinkles on the bottom image with the help of
the Pen Tool series (P).

In this mode, paths of wrinkles can be
created inside the boundary box from left/top
to right/bottom. The portions outside the right
edge/bottom edge of the boundary box will be
completed inside the boundary box from left/
bottom. Meanwhile, the initial anchors and
terminal anchors will be assembled on the left
edge and top edge. Take advantage of these
conveniences and automations; adjust the paths
in order to make sure uniformity, continuity and
extensibility with paths on adjacent tiles on the
premise that there are no significant changes
compared with referencing wrinkles, especially
the anchors assembled on the boundary box
edges.
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Pattern Options
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Figure 4. Extact skeleton of wrinkles in Al pattern editing mode

With the observation of wrinkles, the
widths of the them are observably changeful. In
order to generate this effect, create a calligraphic
brush in the Brushes Panel with the parameters

Pattern Options

Name: SRP of LGL-Grid-Final

Tile Type: B Grid

5x3

Dim Copies to:  100%

Show Tile Edge
Show Swatch Bounds

3 5
- wrinklebrush ___ g

as Angle=45°, Roundness=35% and Size=2 pt.
Select all the created paths and click the new
brush in Brushes Panel, resulting in the paths
turning into diverse wrinkles immediately.

Brushes Symbols

Figure 5. Simulate wrinkles of LGL using paths and calligraphic brush

With the aim of
stereoscopic LGL surface effect, highlighting is an
essential element. Select all the wrinkles, make
a copy of them (Cmd/Ctrl + C) and paste in back
(Cmd/Ctrl + B). Click the Transform Panel, add 2
px each on the X Value and Y Value and change
the Fill Color into R=255, G=25 and B=255. Go
to Pathfinder (Cmd/Ctrl + Shift + F9) and check
the Unite option to create a compound shape.

simulating more

Open the Transparency Panel, set the Blending
Mode as Overlay with Opacity=50%. Go to Effect
> Stylize > Feather and set the Radius=2px. The
setting of this process can create a more natural
highlight effect and in addition, the overlay
blending mode will eliminate the effect of
highlights on the wrinkles of adjacent tiles.
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Generate Pores of LGL Surface

The pores reveal uneven features on the
LGL surface while utilizing the Symbol Sprayer
Tool could express this feature quickly. First,
enlarge the referencing image in order to
observing the details of the pores. Use the Pen
Tool to outline one of the pores’ shape. Fill the
gradient from white to black, adjust the angle
consistent with the angle of the highlight by

Symbol Options

Export Type: MovieClip v
Symbol Type: © Dynamic Symbol
O Static Symbol

Registration §§§

[C] Enable Guides for 9-Slice Scaling

“Movie Clip® and "Graphic"” are tags for Flash
import. There is no difference between these two
symbols in lllustrator.

using the Gradient Tool whose type is radial;
Stroke in white and use the wrinkle brush that
was created earlier; set the Blending Mode as
Overlay with Opacity=70%. Feather it with the
Radius=1.5px and drag it into the Symbols Panel,
naming it Pore. These parameters can be seen in
the Appearances Panel in Figure 6. The setting
of this process can create a more natural pore
effect.

ushes  Symbols

M.

Appearance  Graph

No Selection
stroke: [l] wrinkle brush
Fill:
Feather
Opacity: 70% Overlay

m ®© 1
C nt ¢ Transparency

v Opacity: 70% >

Figure 6. Simulate pores symbol of LGL referring to the realistic feature

Select the Pore symbol created earlier
and use the Symbol Sprayer Tool (shift + S) and
other subtools to spray and adjust the pores.
Double click the Symbol Sprayer Tool and set the
parameters of Intensity and Symbol Set Density
while keeping the other options as default.
With the purpose of keeping the integrity of all
pores, do not spray them on or outside the left
and top edge of the boundary box, Press the
Option/Alt key and use the Symbol Sprayer Tool
to erase them when it happens; however the
Pore symbol can be sprayed beyond the right
and bottom edge while the excessive portions
appear inside the boundary box on the opposite
direction simultaneously. Use the Symbol Shifter,
Scruncher and Sizer Tool to adjust the size
and density of the pores. This process can be
accomplished in a few steps in order to adjust
the pores with different sizes separately as well
as show different density.

delete the
stereomicroscope image in the last layer and fill

Finally, raster scanning
the rectangle at penultimate layer color with any
RGB, except with the same color as the wrinkle.
Highlight and click on the Done button. The new
seamless pattern has been saved in the Swatches
panel. Save it in the root directory, allowing it to

be used as afill for any objects in Al in the future.

Generate Tiles of LGL Surface Used in Other
Software

Theformatof PNG, which ownstransparent
background, is necessary in order to expand
the application of QCP of LGL in other software
such as texture mapping of a three-dimensional
design. Drag the new pattern from the Swatches
panel to the artboard where several tiles will
splice together. Ungroup these objects select the
rectangle, which acts as the boundary box in the
center, and bring it to the front (Cmd/Ctrl + shift
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+]). Select all of the objects, go to Pathfinder
(Cmd/Ctrl + shift +F9), and click on Crop option.
Objects outside the boundary box will be deleted
directly and the parameters of the highlights and
pores should be set again as Blending Mode is

IN ADOBE ILLUSTRATOR CC
Overlay, Opacity=70%. After go to Effect > Stylize
> Feather, and set the Radius=1.5px. Delete the
entire highlight if the pattern tile is used in three-
dimensional software. Finally, go to File > Export,
and export the tile as PNG format.

Figure 7. PNG pattern tile exported from Al with transparent background

RESULTS

Based on the stereomicroscope image of
LGL, the method of generating Grid type QCP of
LGL in Al using the Pattern Editing Mode could
simulate the stereoscopic characteristic of LGL
surface easily and quickly.

Except for Grid tile, the position of pattern
tiles could be offset horizontally, vertically, or
hexagonally using the type of Brick by row, Brick
by column, Hex by column, and Hex by row in

the Pattern Option panel, which could generate
more varied QCP of LGL.

Besides the finding that designers can
modify and transform the scale, the angle of litchi
grain conveniently resulting from the properties of
vectorial graphics made in Al could simulate various
appearances of LGL surface. Moreover, the other
format files exported from Al could be used for
texture mapping and rending with high resolution
in three-dimensional leather products design.
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Figure 8. Different appearances of LGL filled with QCP generated in Al

DISCUSSION

The main goal of this study was to attempt
to find a way to simulate the LGL products
with realistic appearances efficiently. When
comparing our results with studies by Miyata
et al., a method for generating leather texture
by means of particle simulation and blobby
model were introduced [4, 8, 11]. This method
initiatively generated a cell arrangement pattern
using a 3D particle model while the detailed
surface geometry was then created by applying
a blobby model. Users could create various
types of realistic leather textures with ease by
simply choosing a cell arrangement type and
selecting directionality for each section, along
with inputting control parameters in the texture
generator.

Similar with the methods of Miyata,
Sakurai et al. described a method for procedural
leather texture generation focusing on structural
leather elements and based on Voronoi
diagrams and mass-spring model [7, 12, 13].
They explicitly tried to simulate realistic leather
with a continuous surface by forming pores and
sulci by modifying the nodes of the diagram and
applying radial basis function, respectively.

Although the work of research discussed
above have provided solutions to solve these
issues, it has been very difficult for leather

products designers to design an algorithm that
is both efficient and capable of generating a high
quality continuous LGL tile, as well as input it to
professional and generic software to use. The
methods introduced in this study adopted the
generic software with the Pattern Making Mode,
which consists of Grid Tile, Brick Tile, and Hex Tile
and could create various surface appearances
of LGL quickly and effectively without using an
algorithm. In addition, this method comes with
all the advantages of vectorgraph properties,
such as large-scale coverability, transformability,
and easy-modifiability.

There were also limitations in this study.
First and most importantly, the repetition of LGL
patterns looked apparent and distracting when
objects were zoomed out to a certain degree.
This resulted from wrinkles that should be
compensated and adjusted when creating the
QCP using any Tile type, as only one portion of the
LGL surface was referenced. Several stochastic
algorithms were introduced to non-periodically
tile the object with a small set of Wang Tiles [14],
consisting of square tiles with color-coded edges,
in order to create large expanses of complex
patterns without an obvious repetitive feature
[15]. In addition, with blur texture on the surface
of LGL, the captured image shows thick or thin
texture and color difference, as it was difficult
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to capture precise features with the observance
of the naked eye, even though the referencing
image was under the stereomicroscope. Some
researchers use the canny edge detection
operator and watershed algorithm [16] to extract
the texture of the leather image. Canny operator
can effectively extract the main texture, while
the watershed algorithm can fully express the
texture details. These methods can effectively
extract the texture information from the leather
image.

Future work in this study could combine
the advantage of generating QCP in Al, algorithm
design, and texture extraction methods in order
to simulate surface of LGL without obvious
repetitive trail when zoomed out it in any degree.
Furthermore, future work is needed to simulate
surface of LGL precisely according to the data
calculated by the texture extraction methods.

CONCLUSION

The difficulty of simulating realistic
LGL surface limits the creations of leather
products designers. Fortunately, the application
of generating QCP in Pattern Editing Mode
created by Al solved this issue without using
any algorithm. The generations of QCP used in
LGL products design sketch were no longer time
consuming and the surfaces of LGL did not appear
to be artificial as the simulation referencing the
scanning LGL sample image under 10 times the
stereomicroscope. The efficiencies of creation,
modification and transformation could be
improved as well as the pattern tile exported
from Al, which showed excellent effect when

mapping texture in three-dimensional software.
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